CED VideoDisc and Player Discussion Forum Index CED VideoDisc and Player Discussion
Forum topics can be anything related to SelectaVision CED's, and could include offers to buy/sell/trade, repair advice, historical anecdotes, caches of CED's you've discovered, etc.

Click on the Register link to join.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

SFT 100 W problem

 
Post new topic   Reply to topic    CED VideoDisc and Player Discussion Forum Index -> General
View previous topic :: View next topic  
Author Message
flemingb



Joined: 13 Dec 2004
Posts: 5

PostPosted: Fri Dec 24, 2004 7:51 pm    Post subject: SFT 100 W problem Reply with quote

I have a SFT 100W and it cannot pull the pick up arm off the spring when starting a film.The player plays fine after ten minutes into the film. The first ten minutes something seems to keep enough hold on the servo mechanism that it will not pull ahead it just stays in the one position. WIth a little tap on the one gear it moves on ahead but gets stuch again and you have to tap it again. I have already tried all the trouble shoots at CED magic .com Are there any other solutions or could have I done something wrong.
Back to top
View user's profile Send private message AIM Address
Andy



Joined: 31 May 2004
Posts: 4

PostPosted: Mon Dec 27, 2004 10:16 pm    Post subject: Reply with quote

Have you tried lubricating the mechanism? It's possible that there's just too much friction near the start of the disc. After more than 20 years, the original lubrication is probably pretty worthless.
Back to top
View user's profile Send private message AIM Address
Surge



Joined: 16 Jan 2005
Posts: 14
Location: Music City

PostPosted: Sun Jan 16, 2005 1:35 am    Post subject: Reply with quote

Andy wrote:
Have you tried lubricating the mechanism? It's possible that there's just too much friction near the start of the disc. After more than 20 years, the original lubrication is probably pretty worthless.


Right on it Andy....use white lithium grease....will last alot longer,and no worries of heating up and getting the splattering effect.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    CED VideoDisc and Player Discussion Forum Index -> General All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group